Endlos-Netzsuche trotz Verbindung

Problemhilfe zur Nutzung von MWconn
Forumsregeln
Um eine schnellere Hilfe bei nicht offensichtlichen Problemen zu bieten, ist es oft erforderlich, ein so genanntes Servilog wiki/index.php/Serviceprotokoll zu erstellen.
Antworten
fstorm
Beiträge: 2
Registriert: So 19. Dez 2010, 17:31

Endlos-Netzsuche trotz Verbindung

Beitrag von fstorm » Di 8. Feb 2011, 18:10

Hallo zusammen,

mit einem Huawei K3565 (Vodafone) und einer nepalesischen Ncell-SIM-Karte (kein Scherz) habe ich (hier in Nepal) das Problem, dass MWconn im UMTS-Modus endlos "Bitte warten. Netzsuche läuft." anzeigt, obwohl ich problemlos über die Windows-Netzwerkverbindungen die von MWconn dafür angelegte Verbindung "Internet" manuell verbinden kann und dann auch Internet-Zugriff habe. Bei der Verwendung von GPRS funktioniert alles normal.
Netlock ist auch keiner drauf - mit diversen anderen SIM-Karten hat es in anderen Ländern auch im UMTS-Modus problemlos funktioniert.

Anbei die beiden servilogs - servilog_GPRS funktioniert, servilog_UMTS funktioniert nicht. Mir scheint, dass das Modem im UMTS-Modus bei AT+COPS=3,0 keinen sinnvollen Netznamen zurückgibt (nur +COPS: 1,0,"",2) und dass MWconn darüber stolpert - aber das ist nur ein Stochern im Nebel ;-)

Ansonsten ist MWconn übrigens super!!!

Vielen Dank und viele Grüße,
Felix
Dateianhänge
servilog_GPRS.txt
(24.97 KiB) 101-mal heruntergeladen
servilog_UMTS.txt
(5.43 KiB) 113-mal heruntergeladen

lagoon
Beiträge: 1782
Registriert: So 21. Sep 2008, 22:01

Re: Endlos-Netzsuche trotz Verbindung

Beitrag von lagoon » Di 8. Feb 2011, 22:25

fstorm hat geschrieben:... Mir scheint, dass das Modem im UMTS-Modus bei AT+COPS=3,0 keinen sinnvollen Netznamen zurückgibt (nur +COPS: 1,0,"",2) und dass MWconn darüber stolpert - aber das ist nur ein Stochern im Nebel ;-)...
Klingt plausibel, auch die Medung im Log stützt das ... :o

fstorm
Beiträge: 2
Registriert: So 19. Dez 2010, 17:31

Re: Endlos-Netzsuche trotz Verbindung

Beitrag von fstorm » Mi 9. Feb 2011, 06:01

Gäbe es denn für dieses Problem irgendeinen Workaround, irgendeine versteckte Einstellung in der Konfiguration von MWconn, die dazu führt, dass MWconn auch einen leeren String als Netznamen akzeptiert? Die Rückgabe +COPS: 1,0,"",2 erscheint ja zumindest syntaktisch korrekt, wenn auch vom Inhalt her nur teilweise hilfreich ;-)

Ich glaube leider nicht, dass ich vom Provider eine andere/"bessere" SIM-Karte bekomme oder dass der für mich sein Netz umstellt - zumal der Netzname angezeigt wird, wenn ich die SIM in mein Handy einlege und das UMTS-Netz auswähle...

Vielen Dank,
Felix

P.S.: Ein Firmware-Update des Modems auf Version 11.609.10.00.00 hat leider auch nichts gebracht...

lagoon
Beiträge: 1782
Registriert: So 21. Sep 2008, 22:01

Re: Endlos-Netzsuche trotz Verbindung

Beitrag von lagoon » Mi 9. Feb 2011, 09:17

Liegt sehr wahrscheinlich wirklich an der Konfig des Netzes vor Ort ... :( Wenn sich da was machen lässt, dann müsste Markus es "umsticken". Wende Dich am besten mal direkt an ihn: PN an Opilionn oder per Mail - viel Erfolg!

Opilionn
Administrator
Beiträge: 719
Registriert: Sa 26. Jul 2008, 18:25

Re: Endlos-Netzsuche trotz Verbindung

Beitrag von Opilionn » Do 10. Feb 2011, 21:21

lagoon hat geschrieben:Wenn sich da was machen lässt, dann müsste Markus es "umsticken".
Genau richtig. :-) Danke euch beiden! Felix für die Protokolle und die erstklassige Analyse, lagoon sowieso für die vielen Tipps, die er hier im Forum postet!

Ab Version 5.7H sollte das Problem nun nicht mehr auftreten. Felix habe ich schon gemailt, aber ich wollte hier trotzdem eine Info reinsetzen; vielleicht hat ja jemand anders das gleiche Problem.

Schönen Abend!
Opilionn

Antworten