Blödes Problem: Ich kenne meine PIN nicht mehr...

Problemhilfe zur Nutzung von MWconn
Forumsregeln
Um eine schnellere Hilfe bei nicht offensichtlichen Problemen zu bieten, ist es oft erforderlich, ein so genanntes Servilog wiki/index.php/Serviceprotokoll zu erstellen.
enJOyIT
Beiträge: 18
Registriert: Sa 16. Jan 2010, 22:08

Blödes Problem: Ich kenne meine PIN nicht mehr...

Beitrag von enJOyIT » Mo 18. Okt 2010, 22:57

Hallo ich bräuchte mal Hilfe. Ich habe meine PIN zur SIM verlegt. MWconn läuft ohne Probleme, da diese ja abgespeichert ist. Nur ich wollte den Stick jetzt an einen UMTS-Router anschließen, dieser verlangt die Eingabe des zugehörigen PINs.

Könnte mich irgendwie ein Admin kontaktieren, welchem ich diese CRYPTxxxx aus der ini zuschicken kann und dieser mir die PIN im Klartext mitteilt?

Wäre echt klasse!

gruß

Benutzeravatar
Hammergott
Beiträge: 574
Registriert: Do 17. Dez 2009, 02:12
Wohnort: 25524/Schleswig-Holstein

Re: Blödes Problem: Ich kenne meine PIN nicht mehr...

Beitrag von Hammergott » Mo 18. Okt 2010, 23:12

Hallo enJOyIT,

am besten wird dir da zwar Markus/Opilionn/Autor antworten können,

doch ich denke nicht das das irgendwo vorgesehen ist, allein schon wegen

"User-Schutz"! Wenn du die Puk/Superpin noch hast, einfach in Handy ein-

legen, 3 mal verkehrte Pin, Puk/Superpin eingeben und neue Pin vergeben.

MfG

Hammergott
Home: FRITZ!Box 7530 (UI)
Mobil: ZTE MF667
Home: 1&1 DSL 50
Mobil: T-Mobile
Möge der Hammergott mit Euch sein!

enJOyIT
Beiträge: 18
Registriert: Sa 16. Jan 2010, 22:08

Re: Blödes Problem: Ich kenne meine PIN nicht mehr...

Beitrag von enJOyIT » Mo 18. Okt 2010, 23:28

Ja, wenn ich die PUK noch hätte. Beide Briefe befinden sich, wenn überhaupt zusammen irgendwo im nirgendwo...

Hab jetzt schon dieses Pants-Off probiert um die Sternchen in Klartext zu verwandeln. Hab die Com-Schnittstelle überwacht, bloß da kann ich die PIN auch nicht extrahieren. So ein Mist... :/

Benutzeravatar
Hammergott
Beiträge: 574
Registriert: Do 17. Dez 2009, 02:12
Wohnort: 25524/Schleswig-Holstein

Re: Blödes Problem: Ich kenne meine PIN nicht mehr...

Beitrag von Hammergott » Mo 18. Okt 2010, 23:34

Das ist natürlich übel :( , dann bleibt leider nur noch auf Markus zu warten, ob der

noch eine Idee/Lösung hat!

MfG

Hammergott
Home: FRITZ!Box 7530 (UI)
Mobil: ZTE MF667
Home: 1&1 DSL 50
Mobil: T-Mobile
Möge der Hammergott mit Euch sein!

lagoon
Beiträge: 1782
Registriert: So 21. Sep 2008, 22:01

Re: Blödes Problem: Ich kenne meine PIN nicht mehr...

Beitrag von lagoon » Di 19. Okt 2010, 07:26

Soweit ich weiß, wird die PIN im Klartext zum Modem geschickt - Du müsstest lediglich die Kommunikation mit dem Port "mithören". Irgendwo hier im Forum hat Markus die Frage schon mal beantwortet, wenn ich mich recht erinnere ... es besteht also noch Hoffnung ;)

Edit: Die SuFu hilft -> http://www.mwconn.info/viewtopic.php?f= ... ssen#p3343 :o

enJOyIT
Beiträge: 18
Registriert: Sa 16. Jan 2010, 22:08

Re: Blödes Problem: Ich kenne meine PIN nicht mehr...

Beitrag von enJOyIT » Di 19. Okt 2010, 08:58

Ich habe die Kommunikation über den Com-Port ausgelesen. Nur an der, für mich, vermeintlichen Stelle wird der PIN nicht im Klartext übertragen. Müsste irgendwas mit "AT+PIN" oder so sein. Nur da kommt dann nur "...READY..OK" oder sowas. Aber vielleicht schaue ich an der falschen Stelle?

gruß

enJOyIT
Beiträge: 18
Registriert: Sa 16. Jan 2010, 22:08

Re: Blödes Problem: Ich kenne meine PIN nicht mehr...

Beitrag von enJOyIT » Di 19. Okt 2010, 09:07

So, hab jetzt mal die Stelle herauskopiert welche ich meine:

Code: Alles auswählen

0.00002011	MWconn.exe	IOCTL_SERIAL_PURGE	QCUSB_COM4_1	SUCCESS	Purge: TXABORT RXABORT TXCLEAR RXCLEAR	
0.00022265	MWconn.exe	IRP_MJ_WRITE	QCUSB_COM4_1	SUCCESS	Length 12: AT+COPS=3,0.	
0.03125369	MWconn.exe	IRP_MJ_READ	QCUSB_COM4_1	TIMEOUT	Length 6: ..OK..	
0.00002011	MWconn.exe	IOCTL_SERIAL_PURGE	QCUSB_COM4_1	SUCCESS	Purge: TXABORT RXABORT TXCLEAR RXCLEAR	
0.00032323	MWconn.exe	IRP_MJ_WRITE	QCUSB_COM4_1	SUCCESS	Length 9: AT+CPIN?.	
0.03109865	MWconn.exe	IRP_MJ_READ	QCUSB_COM4_1	TIMEOUT	Length 22: ..+CPIN: READY....OK..	
0.00001956	MWconn.exe	IOCTL_SERIAL_PURGE	QCUSB_COM4_1	SUCCESS	Purge: TXABORT RXABORT TXCLEAR RXCLEAR	
0.00024500	MWconn.exe	IRP_MJ_WRITE	QCUSB_COM4_1	SUCCESS	Length 10: AT+CREG=2.	
0.03115228	MWconn.exe	IRP_MJ_READ	QCUSB_COM4_1	TIMEOUT	Length 6: ..OK..	
0.00002207	MWconn.exe	IOCTL_SERIAL_PURGE	QCUSB_COM4_1	SUCCESS	Purge: TXABORT RXABORT TXCLEAR RXCLEAR	
0.00032378	MWconn.exe	IRP_MJ_WRITE	QCUSB_COM4_1	SUCCESS	Length 38: AT+CGDCONT=1,"IP","internet.t-mobile".	
0.03126822	MWconn.exe	IRP_MJ_READ	QCUSB_COM4_1	TIMEOUT	Length 6: ..OK..	
0.00001983	MWconn.exe	IOCTL_SERIAL_PURGE	QCUSB_COM4_1	SUCCESS	Purge: TXABORT RXABORT TXCLEAR RXCLEAR	
0.00032239	MWconn.exe	IRP_MJ_WRITE	QCUSB_COM4_1	SUCCESS	Length 9: AT+CREG?.	
0.03116458	MWconn.exe	IRP_MJ_READ	QCUSB_COM4_1	TIMEOUT	Length 35: ..+CREG: 2,1, 58002C, B2F4B....OK..	
0.00002039	MWconn.exe	IOCTL_SERIAL_PURGE	QCUSB_COM4_1	SUCCESS	Purge: TXABORT RXABORT TXCLEAR RXCLEAR	
0.00024221	MWconn.exe	IRP_MJ_WRITE	QCUSB_COM4_1	SUCCESS	Length 10: AT+CREG=2.	
ist die falsche Stelle, oder?

lagoon
Beiträge: 1782
Registriert: So 21. Sep 2008, 22:01

Re: Blödes Problem: Ich kenne meine PIN nicht mehr...

Beitrag von lagoon » Di 19. Okt 2010, 10:37

Sorry, da muss ich passen. Vielleicht kann Markus noch etwas weiter helfen ... :?:

Edit: Es könnte natürlich sein, dass die PIN nur einmal ganz am Anfang bei der Modeminitialisierung übertragen wird. Später prüft MWconn dann nur noch, ob die PIN schon mal korrekt übertragen worden ist. Am besten probierst Du es noch mal ganz von vorn ... ;)

enJOyIT
Beiträge: 18
Registriert: Sa 16. Jan 2010, 22:08

Re: Blödes Problem: Ich kenne meine PIN nicht mehr...

Beitrag von enJOyIT » Di 19. Okt 2010, 10:54

Ok, nochmal von vorne bis zur oben geposteten Stelle...

Code: Alles auswählen

0.00196897	MWconn.exe	IRP_MJ_CREATE	QCUSB_COM4_1	SUCCESS	Options: Open 	
0.00001117	MWconn.exe	IOCTL_SERIAL_GET_BAUD_RATE	QCUSB_COM4_1	SUCCESS		
0.00000587	MWconn.exe	IOCTL_SERIAL_GET_LINE_CONTROL	QCUSB_COM4_1	SUCCESS		
0.00000615	MWconn.exe	IOCTL_SERIAL_GET_CHARS	QCUSB_COM4_1	SUCCESS		
0.00000559	MWconn.exe	IOCTL_SERIAL_GET_HANDFLOW	QCUSB_COM4_1	SUCCESS		
0.00000587	MWconn.exe	IOCTL_SERIAL_GET_BAUD_RATE	QCUSB_COM4_1	SUCCESS		
0.00000531	MWconn.exe	IOCTL_SERIAL_GET_LINE_CONTROL	QCUSB_COM4_1	SUCCESS		
0.00000531	MWconn.exe	IOCTL_SERIAL_GET_CHARS	QCUSB_COM4_1	SUCCESS		
0.00000559	MWconn.exe	IOCTL_SERIAL_GET_HANDFLOW	QCUSB_COM4_1	SUCCESS		
0.00000587	MWconn.exe	IOCTL_SERIAL_SET_BAUD_RATE	QCUSB_COM4_1	SUCCESS	Rate: 115200	
0.00000587	MWconn.exe	IOCTL_SERIAL_SET_LINE_CONTROL	QCUSB_COM4_1	SUCCESS	StopBits: 1 Parity: NONE WordLength: 8	
0.00000587	MWconn.exe	IOCTL_SERIAL_SET_CHAR	QCUSB_COM4_1	SUCCESS	EOF:0 ERR:3f BRK:3f EVT:0 XON:11 XOFF:13	
0.00000615	MWconn.exe	IOCTL_SERIAL_SET_HANDFLOW	QCUSB_COM4_1	SUCCESS	Shake:2 Replace:84 XonLimit:0 XoffLimit:0	
0.00001257	MWconn.exe	IOCTL_SERIAL_GET_TIMEOUTS	QCUSB_COM4_1	SUCCESS		
0.00000559	MWconn.exe	IOCTL_SERIAL_SET_TIMEOUTS	QCUSB_COM4_1	SUCCESS	RI:0 RM:0 RC:20 WM:0 WC:5000	
0.00000559	MWconn.exe	IOCTL_SERIAL_SET_QUEUE_SIZE	QCUSB_COM4_1	SUCCESS	InSize: 4196 OutSize: 4196	
0.00000391	MWconn.exe	IOCTL_SERIAL_SET_WAIT_MASK	QCUSB_COM4_1	SUCCESS	Mask: RXCHAR ERR 	
0.00000894	MWconn.exe	IOCTL_SERIAL_PURGE	QCUSB_COM4_1	SUCCESS	Purge: TXABORT RXABORT TXCLEAR RXCLEAR	
0.00000643	MWconn.exe	IOCTL_SERIAL_PURGE	QCUSB_COM4_1	SUCCESS	Purge: TXABORT RXABORT TXCLEAR RXCLEAR	
0.00029333	MWconn.exe	IRP_MJ_WRITE	QCUSB_COM4_1	SUCCESS	Length 3: AT.	
0.03122492	MWconn.exe	IRP_MJ_READ	QCUSB_COM4_1	TIMEOUT	Length 6: ..OK..	
0.00001983	MWconn.exe	IOCTL_SERIAL_PURGE	QCUSB_COM4_1	SUCCESS	Purge: TXABORT RXABORT TXCLEAR RXCLEAR	
0.00032937	MWconn.exe	IRP_MJ_WRITE	QCUSB_COM4_1	SUCCESS	Length 4: ATI.	
0.03122687	MWconn.exe	IRP_MJ_READ	QCUSB_COM4_1	TIMEOUT	Length 132: ..Manufacturer: ZTE INCORPORATED..Model: MF637..Revision: BD_TMO	
0.00001956	MWconn.exe	IOCTL_SERIAL_PURGE	QCUSB_COM4_1	SUCCESS	Purge: TXABORT RXABORT TXCLEAR RXCLEAR	
0.00024696	MWconn.exe	IRP_MJ_WRITE	QCUSB_COM4_1	SUCCESS	Length 5: AT&F.	
0.03130985	MWconn.exe	IRP_MJ_READ	QCUSB_COM4_1	TIMEOUT	Length 6: ..OK..	
0.00001872	MWconn.exe	IOCTL_SERIAL_PURGE	QCUSB_COM4_1	SUCCESS	Purge: TXABORT RXABORT TXCLEAR RXCLEAR	
0.00033049	MWconn.exe	IRP_MJ_WRITE	QCUSB_COM4_1	SUCCESS	Length 17: ATE0V1&D2&C1S0=0.	
0.03335675	MWconn.exe	IRP_MJ_READ	QCUSB_COM4_1	TIMEOUT	Length 6: ..OK..	
0.00002011	MWconn.exe	IOCTL_SERIAL_PURGE	QCUSB_COM4_1	SUCCESS	Purge: TXABORT RXABORT TXCLEAR RXCLEAR	
0.00022265	MWconn.exe	IRP_MJ_WRITE	QCUSB_COM4_1	SUCCESS	Length 12: AT+COPS=3,0.	
0.03125369	MWconn.exe	IRP_MJ_READ	QCUSB_COM4_1	TIMEOUT	Length 6: ..OK..	
0.00002011	MWconn.exe	IOCTL_SERIAL_PURGE	QCUSB_COM4_1	SUCCESS	Purge: TXABORT RXABORT TXCLEAR RXCLEAR	
0.00032323	MWconn.exe	IRP_MJ_WRITE	QCUSB_COM4_1	SUCCESS	Length 9: AT+CPIN?.	
0.03109865	MWconn.exe	IRP_MJ_READ	QCUSB_COM4_1	TIMEOUT	Length 22: ..+CPIN: READY....OK..	

Fredo
Beiträge: 7
Registriert: Fr 10. Sep 2010, 14:26

Re: Blödes Problem: Ich kenne meine PIN nicht mehr...

Beitrag von Fredo » Di 19. Okt 2010, 11:28

Zieh mal den Stick ab, steck ihn wieder dran und starte dann MWconn. Dann solltest du im Mitschnitt auch die Konfiguration der PIN sehen.

Gruß,
Frederik

Antworten